Принудительная перезагрузка удаленно

https://geektimes.ru/post/117083/
http://www.pufik.org/article/windows/soft-reset

Удаленная перезагрузка ПК если psshutdown и стандартные вызовы не работают.
Программная «жесткая» перезагрузка.

ForceReboot

Или
Принудительно завершить win32 subsystem (csrss.exe)
1.Проверить что опция «Автоматическая перезагрузка при крахе системы» включена
2.>pskill \\COMPUTERNAME -u User -p password csrss.exe

Мониторинг VoIP канала с помощью Zabbix

Мониторинг VoIP канала с помощью Zabbix
https://voipnotes.ru/monitoring-voip-channel-zabbix/

RDS Shadow – подключаемся к сессии пользователя в Windows 2012 R2

http://winitpro.ru/index.php/2014/02/12/rds-shadow-v-windows-2012-r2/

RDS Shadow – подключаемся к сессии пользователя в Windows 2012 R2
12.02.2014 Windows Server 2012 R2 Комментарии (25)

Спешим поделиться хорошей новостью: Microsoft вернула функционал Remote Desktop Shadowing в Windows Server 2012 R2 и Windows 8.1! Напомним, что режим Shadow (теневой сеанс) – может использовать администратором для просмотра и управления активной терминальной сессией любого пользователя. Этот режим работы поддерживается практически с первых версий терминального сервера Microsoft и неожиданно был убран в релизе Windows Server 2012 (связано с переносом стека rdp из режима ядра в пользовательский режим).

Кроме того, у режима RD Shadow и rdp клиента появился ряд новых интересных возможностей. Полный список опций rdp клиента mstsc.exe, определяющих возможность удаленного подключения к сессии конечного пользователя:

Mstsc.exe [/shadow:sessionID [/v:Servername] [/control] [/noConsentPrompt]] Новые параметры mstsc в Windows 8.1

/shadow:ID – подключится к терминальной сессии с указанным ID

/v:servername – имя терминального сервера (если не задано, используется текущий)

/control – возможность взаимодействия с сеансом пользователя (если не указано, используется режим просмотра сессии пользователя).

/noConsentPrompt – не запрашивать у пользователя подтверждение на подключение к сессии

Ограничения теневых сеансов RDS в Windows 2012 R2

Подключаться к чужим сессиям может только администратор сервера. Делегировать эти права обычным пользователем нельзя
RDS Shadow не будет работать в сетях на базе рабочих групп

Remote Desktop Shadow — работа в GUI

Подключиться к сессии пользователя можно с помощью утилиты mstsc.exe или непосредственно из консоли Server Manager. Для этого в консоли Server Manager откройте коллекцию QuickSessionCollection. коллекция QuickSessionCollection

Щелкнув по сессии интересующего пользователя, выберите в контекстном меню Shadow. shadow — запуск теневой сесии

Появится окно параметров теневого подключения. Возможен просмотр (View) и управление (Control) сессией. Кроме того можно включить опцию Prompt for user consent (запросить согласие на подключение у пользователя). параметры теневого подключения к терминальной сесиии

Если выбрана опция «Запросить подтверждение», в сессии у пользователя появится запрос:

Winitpro\administrator is requesting to view your session remotely. Do you accept the request? Запрос пользователя о shadow подключении

Если пользователь подтвердит, подключение, администратор увидит его рабочий стол и сможет взаимодействовать с ним. удаленное управление терминальной сесией пользователя в rds windows server 2012r2
Совет. Для отключения от сессии пользователя и выхода из shadow-режима нужно нажать ALT+* на рабочей станции или Ctrl+* на терминальном сервере (если не заданы альтернативные комбинации).

Если же пользователь отклонит подключение, появится окно:
Shadow Error: The operator or administrator has refused the request

The operator or administrator has refused the request
Если же попытаться подключится к сессии пользователя без запроса подтверждения, появится ошибка, сообщающая что такое поведение настроено групповой политикой:
Shadow Error: The Group Policy setting is configured to require the user’s consent. Verify the configuration of the policy settings.

ошибка GPO удаленного shadow подключения

Параметры удаленного управлениями терминальными сессиями пользователя настраиваются политиками Set rules for remote control of Remote Desktop Services user sessions, которые находится в разделе Policies -> Administrative Templates -> Windows components -> Remote Desktop Services -> Remote Session Host -> Connections в пользовательской и «компьютерной» секциях GPO.

Этой политикой можно настроить следующие варианты подключения по RD Shadow:

No remote contol allowed — удаленное управление запрещено
Full Control with users’s permission — полный контроль с разрешения пользователя
Full Control without users’s permission — полный контроль без разрешения пользователя
View Session with users’s permission – наблюдение за сеансом с подтверждением
View Session without users’s permission – наблюдение за сеансом без подтверждения

групповая политика управления подключением к терминальным сесииям пользователей
RDS Shadow из Powershell

Воспользоваться функционалом Remote Desktop Services Shadow можно и из Powershell.

В первую очередь покажем, как получить список сессий на терминальном сервере (сесии пользователей будут сгруппированы в группы в зависимости от их статуса):

Get-RDUserSession | ft Username, UnifiedSessionId, SessionState, HostServer, ApplicationType -GroupBy Sessionstate

Get-RDUserSession Powershell

На данном сервере мы обнаружили три активных терминальных сессии. Подключимся к сессии пользователя с ID сессии 3:

Mstsc /shadow:3 /control

mstsc запуск shadow из powershell
Еще записи по теме: Windows Server 2012 R2

Установка KMS сервера на базе Windows Server 2012 R2
DNSSEC–технология защиты DNS в Windows Server 2012
Настройка VPN сервера на базе Windows Server 2012 R2
Динамическое изменение размеров виртуальных дисков в Windows Server 2012 R2
Включаем Jumbo Frames в Windows Server 2012 R2 Hyper-V

Понравилась статья? Скажи спасибо и расскажи друзьям!
Назад:Резервное копирование почтовой базы Exchange 2013 средствами Windows Server Backup
Вперед:Обзор обновлений безопасности Microsoft за февраль 2014
Комментариев: 25
Оставить комментарий

Павел | 06.06.2014

круто, но ты не написал самого главного — как активировать эту функцию =)
У меня её как не было, так и нет.
Ответить
itpro | 06.06.2014

Хм, этот функционал идет прямо-из-коробки. Насколько я помню ничего включать не нужно. В статье речь идет о версии Windows 2012 R2, возможно ты проверял на простой Windows Server 2012.
Проверь, что в хелпе команды mstsc.exe /? имеется опция /shadow
Ответить
Павел | 09.06.2014

да, ты прав. Прошу за невнимательность
Ответить
myr4ik07 | 11.06.2014

Приветствую, протестировал, все прекрасно работает.Спасибо за знакомство.
Ответить
Pavel | 03.11.2014

нет такой функции. сервер 2012 r2
установлены роли — лицензирование удаленных рабочих столов
посредник подключений
узел сеансов удаленных рабочих столов
Ответить
Тимур | 22.11.2014

У меня тоже нет, но у меня не домен, а рабочая группа, а в ней как написано работать не будет.
Ответить
Антон | 08.03.2015

Спасибо. Получилось. Работает. Но в отличие от 2008R2 не удается сделать сеанс на весь экран. Если у меня с пользователем одинаковые разрешения экрана, то теневой сеанс получается немного ужатым.
Ответить
itpro | 10.03.2015

Есть такая проблема, но как правило, особых неудобств не вызывает
Ответить
Виталий | 14.05.2015

А если я удалил QuickSessionCollection, как мне можно подключаться к пользовательским сессиям из GUI?
Ответить
Shurik | 10.09.2015

Добрый день. Интересует если возможность также подключатся к пользователю(Shadow), только не на терминальном сервере, а на сервере Windows 2012 R2 Hyper-V. И рабочая станция Windows 7
Ответить
Павел | 10.09.2015

на сервере Windows 2012 R2 Hyper-V

Hyper-V это роль сервера для организации хоста с вируталками. Зачем туда постоянно подключаться?
Если же надо подключиться к одной из виртуалок, развернутых на Hyper-V, в режиме наблюдения за сеансом пользователя то вариант удаленный помощник.
Ответить
Shurik | 10.09.2015

Если же надо подключиться к одной из виртуалок, развернутых на Hyper-V, в режиме наблюдения за сеансом пользователя то вариант удаленный помощник.
Удаленный помощник менее удобен. У гостевой ОС Windows 8.1 есть такая возможность http://social.technet.microsoft.com/wiki/contents/articles/19804.remote-desktop-services-session-shadowing.aspx, ищу решение как прикрутить в Windows 7

Ответить
Павел | 17.09.2015

«Remote Server Administration Tools (RSAT) позволяет администраторам управлять ролями и функциями на Windows Server 2008 R2 и Microsoft Server 2012 (Core & Full installation) с компьютера на базе Windows 7 и Windows 8 соответственно. RSAT для Windows 7 может работать только на версиях Enterprise, Professional или Ultimate и позволяет управлять Microsoft Hyper-V Server 2012, однако её функционал будет ограничен, в первую очередь будут недоступны новые настройки сети.»
Еще вариант 5nine Manager 4.0 for Hyper-V.
Так что попробовать поставить а там как получится.
Но все таки решение либо с удаленным помощником, либо с тем же VNC удобнее и проще.
Ответить
Shurik | 17.09.2015

Спасибо за отзыв
Сделал по Вашому совету — удаленный помощник.
Ответить
Alex Lyashkov | 16.11.2015

Проверил у двух клиентов только что…
Итак — все настройки давно сделаны, но ранее точно помню работало так как надо:
На сервере — члене домена AD (но не скажу точно 2008/2008R2/2012) с ролью RDSH c с настройками как в вашей статье

На сервере RDSH я мог msra /offerRA БЕЗ СОГЛАСИЯ пользователей подключатся к их сеансу. А на клиентах — Win7 — согласие требовало. Но как бы этично — на сервере у них RemoteApp (1C) и там нет личной жизни.

Сейчас : изменилась версия — Server 2012R2 msra , настройки GPO в домене и настройки Локальной политики на самом Server 2012R2 RDSH позволяют «Полный контроль без разрешения клиента», но так как надо — без уведомления и разрешения работает только из GUI (Диспетчер серверов-Службы удаленных рабочих столов-Коллекции-Подключения нужный сеанс — правой клавишей Теневая копия)
Почему, черт побери карамба!, это перестал работать через msra работает, но запрашивает уведомление о подключений пользователя и потом разрешение на управление… то есть я запускаю в RDP сессии находясь по RDP на RDSH msra подключаюсь к нему-же (к серверу на котором нахожусь) выбираю сеанс пользователя — и у пользователя выскакивает — «Разрешить пользователю Админ подключение к вашему компьютеру»
И совсем грустно, что mstsc /shadow:3 /control не работает — Ошибка теневого доступа Отказано в доступе.
Не понимаю. Ведь из GUI работает !!!
Ответить
Александр | 16.11.2015

Так — все на так темно, есть светлый лучик
mstsc /shadow:3 /control /noConsentPrompt — и моментально, за 1 секунду видим и управляем пользовательской сессией — да, жаль что в маленьком окошке
Ответить
Alexey | 04.12.2015

В политиках стоит «Full Control without users’s permission» — полный контроль без разрешения пользователя.
Получаем список id сессий командой «qwinsta».
При попытке запустить «mstsc /shadow:3 /control /noConsentPrompt» получаю ошибку: Ошибка теневого доступа Отказано в доступе.
Выполнение команды «mstsc /shadow:3″ приводт к такой же ошибке.
Подскажите в какую строну копать?
MSRA работает, но при условии что запрос на помощь примут!
Ответить
Александр | 04.12.2015

мне хватило добавить /noConsentPrompt и заработало
Ответить
Adminny | 04.12.2015

Проверь. Должно быть так:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp]
«fInheritShadow»=dword:00000000
«Shadow»=dword:00000002
Ответить
Александр | 16.11.2015

mstsc /shadow:3 /control /noConsentPrompt — работает так как надо! Итого — осталось с MSRA разобраться, или понять, или простить…
Ответить
Adminny | 24.11.2015

Для удобства/быстроты подключения сделал простой ps-скриптик на раб.столе:

Write-Host »
»
quser
$user = Read-Host -Prompt »
Enter ID»
mstsc /shadow:$user /control /noConsentPrompt

PS
Команда quser выполняется моментально в отличие от долгодумающей Get-RDUserSession
Ответить
Я | 02.01.2017

При подключении и отключении от сеанса юзера, экран так же мигает как в 2008r2?
Ответить
Кирилл | 01.08.2017

При попытке подключится в сессию пользователя через GUI — выдаёт: Неопознанная ошибка.

Есть идеи?
Ответить
itpro | 01.08.2017

Подключаетесь с самого сервера? Права администратора имеются?
Ответить
itpro | 01.08.2017

Чтобы разрешить пользователям (членам определенной группы, например,corp\RDSSupport) без прав администратора подключаться к сессии других пользователей через shadow нужно выполнить такую команду:
wmic /namespace:\\root\CIMV2\TerminalServices PATH Win32_TSPermissionsSetting WHERE (TerminalName=»RDP-Tcp») CALL AddAccount «corp\RDSSupport»,2
Ответить

Полные правила комментирования на сайте winitpro.ru. Вопросы, не связанные с содержимым статьи или ее обсуждением удаляются.

Сказать Спасибо! можно на этой странице или (еще лучше) поделиться с друзями ссылкой на понравившуюся статью в любимой социальной сети(специально для этого на сайте присуствуют кнопки популярных соц. сетей).

petya

https://support.microsoft.com/az-latn-az/help/2696547/how-to-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and-windows
https://habrahabr.ru/company/infosecurity/blog/331788/wanna_petya_7

vms linux

VMS_1.0.0_20150820_install_run
ПО под ОС Linux для работы с видеорегистраторами и IP видеокамерами PolyvisionPolyvision_VMS_V1.20.0.13.T.20160519.exe

https://habrahabr.ru/company/intems/blog/322634/

socks proxy

Install SOCKS proxy server on CentOS 7(Dante)


https://la2ha.ru/dev-seo-diy/unix/socks5-proxy-server-ubuntu

Установка настройка dante + radius авторизация в Centos 6.4

Установка socks5 proxy server на VPS под CentOS

Неизвестное устройство elite4 2.x

Используется в качестве ключа для банк-клиентов iBank2. Стандартный пакет драйверов iBank2 не помог его установить в системе.

Идентифицируется по ID

USB\VID_0471&PID_485D&REV_0303
USB\VID_0471&PID_485D

Помогает установка драйвера senselock_windows_3.1.0.0 с сайта http://senselock.ru/
fdok_kg

Неизвестное устройство elite4 2.x

Убийство локальных хранилищь xenserver

Удаление локального хранилища (local storage) в XenServer 6.5

mikrotik vlan

https://habrahabr.ru/post/322720/
https://wiki.mikrotik.com/wiki/Manual:CRS_examples
https://wiki.mikrotik.com/wiki/Manual:Switch_Chip_Features
https://wiki.mikrotik.com/wiki/%D0%A0%D1%83%D0%BA%D0%BE%D0%B2%D0%BE%D0%B4%D1%81%D1%82%D0%B2%D0%B0:%D0%92%D0%BE%D0%B7%D0%BC%D0%BE%D0%B6%D0%BD%D0%BE%D1%81%D1%82%D0%B8_%D1%87%D0%B8%D0%BF%D0%B0_%D0%BA%D0%BE%D0%BC%D0%BC%D1%83%D1%82%D0%B0%D1%86%D0%B8%D0%B8


https://wiki.mikrotik.com/wiki/Vlans_on_Mikrotik_environment

http://www.lanmart.ru/blogs/how-to-become-isp-3
http://www.wirelessinfo.be/index.php/mikrotik/pages/vlan

микротик vlan

mikrotik backup 6

mikrotik backup wiki

{
:log info "Starting Backup Script...";
:local sysname [/system identity get name];
:local sysver [/system package get system version];
:log info "Flushing DNS cache...";
/ip dns cache flush;
:delay 2;
:log info "Deleting last Backups...";
:foreach i in=[/file find] do={:if ([:typeof [:find [/file get $i name] \
"$sysname-backup-"]]!="nil") do={/file remove $i}};
:delay 2;
:local smtpserv [:resolve "smtp.gmail.com"];
:local Eaccount "your_account@gmail.com";
:local pass "your_gmail_password";
:local backupfile ("$sysname-backup-" . \
[:pick [/system clock get date] 7 11] . [:pick [/system \
clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup");
:log info "Creating new Full Backup file...";
/system backup save name=$backupfile;
:delay 2;
:log info "Sending Full Backup file via E-mail...";
/tool e-mail send from="<$Eaccount>" to=$Eaccount server=$smtpserv \
port=587 user=$Eaccount password=$pass start-tls=yes file=$backupfile \
subject=("$sysname Full Backup (" . [/system clock get date] . ")") \
body=("$sysname full Backup file see in attachment.\nRouterOS version: \
$sysver\nTime and Date stamp: " . [/system clock get time] . " " . \
[/system clock get date]);
:delay 5;
:local exportfile ("$sysname-backup-" . \
[:pick [/system clock get date] 7 11] . [:pick [/system \
clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".rsc");
:log info "Creating new Setup Script file...";
/export verbose file=$exportfile;
:delay 2;
:log info "Sending Setup Script file via E-mail...";
/tool e-mail send from="<$Eaccount>" to=$Eaccount server=$smtpserv \
port=587 user=$Eaccount password=$pass start-tls=yes file=$exportfile \
subject=("$sysname Setup Script Backup (" . [/system clock get date] . \
")") body=("$sysname Setup Script file see in attachment.\nRouterOS \
version: $sysver\nTime and Date stamp: " . [/system clock get time] . " \
" . [/system clock get date]);
:delay 5;
:log info "All System Backups emailed successfully.\nBackuping completed.";
}

 

Все три эти скрипта абсолютно идентичны в плане производимых действий и выполняют следующее (в порядке очерёдности проведения операций):

Затирают DNS-кэш MikroTik’а – я решил, что будет надёжнее исключить возможность резольва DNS-имени сервера исходящей почты Gmail «smtp.gmail.com» в IP-адрес из кэша маршрутизатора — мало ли чего в Google надумают с адресным пространством своих серверов или авария какая (как обычно, в самый неподходящий момент). Бэкап – дело ответственное.
Удаляют файлы бэкапов, созданных при предыдущем запуске данного скрипта – производится во избежание того, чтобы со временем дисковое пространство маршрутизатора не было забито файлами резервных копий. Т.е., единовременно, между запусками вышеприведённых скриптов во внутреннем хранилище самого роутера на базе RouterOS хранится только одна, самая последняя резервная копия (два файла).
Создают файл бэкапа *.backup.
Отправляют сообщение с прикреплённым к нему файлом бэкапа на заданный e-mail-адрес.
Создают файл скрипта настроек *.rsc по команде export.
Отправляют сообщение с прикреплённым к нему файлом скрипта настроек на заданный e-mail-адрес.
Параллельно в системном журнале производится логирование этапов работы запущенного скрипта.

К сожалению RouterOS пока не умеет прикреплять к сообщению более одного файла за раз, поэтому каждый файл приходится отправлять индивидуально.

В результате срабатывания любого из этих скриптов, на указанный вами почтовый адрес придут два сообщения с прикреплёнными к ним файлами:

Остаётся только создать новую запись в планировщике RouterOS (/system scheduler), указав имя вышеприведённого скрипта и задав периодичность его запуска.