Архив для ‘ Scripts ’ Категории

XenConvert vhd import

I used Disk2VHD to create a VHD then using XenConvert 2.3.1, I converted the VHD to OVF. It’s a couple of conversions but it works and imports nicely into XenCenter.

Only XenConvert not works.

http://www.citrixarena.com/2015/09/xen-server-failed-to-import-vhd.htmlxen_failed_import_vhd

mikrotik + резервный канал + проблемы elastix(asterisk)

Сначала стоял Mikrotik с одним каналом инета и было:

/ip firewall nat print
Flags: X - disabled, I - invalid, D - dynamic 
 0    chain=srcnat action=masquerade out-interface=sfp1 log=no log-prefix=""

 

Потом добавил резервного провайдера на eth1 порт и пошли рваться регистрации по тайм-ауту elastix:
sip show registry
Host Username Refresh State Reg.Time
sip.xxx:5060 13xxxx 180 Request Sent
1 SIP registrations.

С начала поставил новый ip для elastix, но через не которое время регистрации начали снова вешаться.
Причем в настройках транка стоял qualify=yes.
Спасала только перезагрузка микротика и elastix сервера, sip reload не помогала!

Asterisk 11.20.0 built by palosanto @ IsoBuilderElx3C7-x64 on a x86_64 running Linux on 2015-12-10 09:29:13 UTC

Что делал:
/ip firewall service-port disable sip

Далее нужно убедиться, что для исходящих пакетов используется правило src-nat, а не маскарад!!

http://podarok66.livejournal.com/4939.html

Jpegoptim сжимаем фотки на шарах

debian & ubuntu
apt-get install jpegoptim
find . -name ‘*.jpg’ | xargs jpegoptim -m85 —strip-all

centos
yum install findutils jpegoptim
find . -name ‘*.jpg’ -print0 | xargs -0 jpegoptim -m85 —strip-all

jpegoptim windows
Жмут все в локальных папках. Не стоит забывать о *.JPG!

Установка Thinstuff LX Server — Терминальный сервер на linux

Я поднимал его на lxde debian 7.
Если из инета уплывет, чтобы у меня сохранилось.
lx_server_manual
Дистриб сервера lxserver-1.2.1-5366.sh

Копи-паст спасибо.
Краткое вступление

Стоит напомнить, что Thinstuff LX Server позволяет получить удаленный доступ к приложениям на основе X11 с помощью протокола Microsoft RDP (Remote Desktop). Что обеспечивает возможность использования как приложений Linux, так и Windows на одном рабочем столе — без необходимости внсить изменения в инфраструктуру.

Поскольку разговаривать мы будем о версии, предназначенной именно для машин с установленным Linux, то все последующие упоминания будут только об этой системе.

[]

Домашняя страница продукта находится по адресу: http://www.thinstuff.com/products/lx-server/

Подробно останавливаться на описании и возможностях продукта я сейчас не буду, с учетом того, что не так давно я вкратце описывал их (LX Server от Thinstuff).

Мне нравятся компании, которые дают возможность проверить работоспособность продукта, предлагая версии с ограничением подключений или с ограничениями по времени использования. Это дает возможность получить общее представление о работоспособности и пригодности для использования в конкретной организации и в конкретных условиях.

Компания Thinstuff также предоставляет такую возможность, чем мы и воспользуемся. Заодно скажу, что для Windows-версии существует 14-дневная триальная версия с полноценными возможностями, а для Linux — версия без ограничений по времени, но зато с ограничением количества подключений и сессий. Оба варианта доступны на следующей странице: http://www.thinstuff.com/downloads-support/downloads/ . Подробней на возможностях оценочной Linux-версии я остановлюсь чуть позже.

На этой же странице (https://www.thinstuff.com/licensing/) можно посмотреть варианты предоставляемого продукта, а также стоимость лицензий на его использование, которая зависит от количества подключений.
Установка

Для начала необходимо получить дистрибутив LX Server.

Переходим в произвольную директорию по вашему выбору. У меня будет /tmp:

cd /tmp
wget [http://www.thinstuff.com/releases/lxserver-1.2.1-5366.sh](http://www.thinstuff.com/releases/lxserver-1.2.1-5366.sh)

Размер — примерно 60 мегабайт, поэтому потребуется какое-то время на скачивание.

—2009-03-16 16:37:59— http://www.thinstuff.com/releases/lxserver-1.2.1-5366.sh
Распознаётся www.thinstuff.com… 78.46.51.238
Устанавливается соединение с www.thinstuff.com|78.46.51.238|:80… соединение установлено.
Запрос HTTP послан, ожидается ответ… 200 OK
Длина: 62484766 (60M) [application/x-binary]
Сохраняется в каталог: `lxserver-1.2.1-5366.sh’.
100%[===============================================>] 62 484 766 115K/s в 7m 52s
2009-03-16 16:45:50 (129 KB/s) — `lxserver-1.2.1-5366.sh’ сохранён [62484766/62484766]

Для установки необходимо получить права пользователя root. Установка под другим пользователем не поддерживается. Запускаем скрипт установщика:

[root@off2 tmp]# bash lxserver-1.2.1-5366.sh
checking archive integrity …
Thinstuff LX Server
(c) Thinstuff s.r.o.
http://www.thinstuff.com
Welcome to the setup routine for the Thinstuff LX Server.
This setup will install the RDP server on your computer in
the directory /opt/thinstuff/rdpserver. The installation
will take about 132 MB of harddisk space.
For more information on non-interactive execution of this
installer please use:
lxserver-1.2.1-5366.sh —help
Please press to continue

Здесь требуется нажать Enter для продолжения.

detecting old installations …
Please choose one of the following actions:
[I]nstall: This installs 1.2.1, build 5366.
[E]xit: Exit installer without changing anything.
Please enter choice (E/I):

В данном случае, поскольку я уже ставил этот продукт, то установщик обнаружил ее. В данном случае нас интересует новая установка, поэтому выбираем I:

Please enter choice (E/I): i
Ready to begin installation. Please press to continue.

Установщик по любому поводу задаются вопросы ))) Что-то мне это напоминает, но сейчас не об этом. Продолжим, нажав Enter.

BY ANSWERING «Y» TO THE PROMPT AT THE END OF THIS TEXT, YOU ARE CONSENTING
TO BE BOUND BY THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF
THIS AGREEMENT, ANSWER «N» TO THE PROMPT AT THE END OF THIS TEXT TO
DISCONTINUE THE INSTALLATION. PLEASE PROMPTLY RETURN THE SOFTWARE PACKAGE
TO Thinstuff s.r.o.
THE FOLLOWING LICENSE GOVERNS YOUR RIGHTS TO THE THINSTUFF LX SERVER(tm)
SOFTWARE. YOU ARE NOT GRANTED ANY RIGHTS IN ANY SOFTWARE INCLUDED IN THIS
SOFTWARE DISTRIBUTION THAT YOU HAVE NOT LICENSED AND FOR WHICH YOU HAVE NOT
PAID THE APPROPRIATE LICENSE FEES TO Thinstuff s.r.o.

1. License. The enclosed computer software and documentation («Software»)
is not being sold and purchased, but is being licensed to you by
Thinstuff s.r.o. («Thinstuff») under a personal, nonexclusive,
nontransferable and paid-up license for use only under the following
terms, and Thinstuff reserves any rights not expressly granted to you
herein. Under the terms of this license you own the media on which the
Software is recorded, but Thinstuff retains all of the rights of
ownership to the Software and all copies of the Software. This license
shall be governed by the laws of the Republic of Austria.

2. Under this license you may:
a.) Make copies of the Software solely for backup or archival purposes.
b.) Make simultaneous use of the Software on a number of computers up
to the number of licenses you purchased for the software.
c.) Transfer your rights under this license for the Software, provided
that you give Thinstuff prior written notice of such transfer and
—Далее—

Предлагается прочитать лицензию на использование. И принять ее:

Do you accept the license (yes/no) ? Yes

Далее будет предложено отправить производителю анонимную информацию о платформе, на которой будет использоваться данный продукт. Эта информация включает в себя тип процессора, версию ядра и другие подобные данные, собранные во время установки. Это опционально, можно отказаться, потому нажмем No.

We would like to collect anonymous information about
the platforms where this product is installed. These
informations would include CPU type, Kernel version
and similar data and would be collected only once
during this setup.
This step is OPTIONAL. If you do not want to send any
information, just answer no to the next question. If
you agree, then the information that is about to be
sent will be displayed before it is actually trans-
mitted.
Would you like to send anonymous system information (yes/no) ? No

И далее следует подготовка и извлечение из архива:

preparing Archive …
extracting Archive …
WARNING: enabling «trust» authentication for local connections
You can change this by editing pg_hba.conf or using the -A option the
next time you run initdb.

* CORBA already running -> skipping
* Starting PostgreSQL: .Done
* lighttpd is already running -> skipping

Finished starting system services…
FINISHED installing database
starting server …

* Starting Configuration Server: .Done
* Proxy Service is already running -> skipping
* Application Launcher is already running -> skipping
* Waiting for RDP server to complete startup:

Finished starting terminalserver services — accepting connections to the
terminalserver
Configuring default session program. Please choose one of the following
options:
[G]nome
[T]wm: Built-in simple windowmanager (default).
Please enter choice (G/T):

Здесь немного остановимся. В комплекте с rdpserver поставляется база данных PostgreSQL и веб-сервер lighttd. При установке проверяется установка этих компонентов и проверка их работоспособности. На некоторых дистрибутивах Linux у меня были проблемы именно на этом шаге. База данных и веб-сервер устанавливались, но установщик не мог подключиться к ним для проверки. При этом lighttpd не мог обнаружить свой файл конфигурации. Это имело место при установке на openSUSE 11.1 и SLED 11 RC1. Может быть, это просто случайность, может еще что-то. Успешная установка была проведена на Fedora 10 и SLES 10 SP2.

Итак, при установке можно выбрать, какой оконный менеджер будет запускаться при входе в систему. В данном случае, поскольку я использую Gnome, то он в пунктах выбора и присутствует. А вот Twm поставляется вместе с LX Server и, если на вашем сервере не ставилась X Window Sustem, то есть возможность использовать именно Twm. Я выбираю Gnome:

Please enter choice (G/T): G
Password (for user root):

Требуется ввести пароль пользователя root. А также потом ответить на вопрос, установить ли скрипт запуска и запускать ли сервис во время старта системы:

Do you want to install the init.d script and start the service on system start
(yes/no) ? Yes
INSTALLATION COMPLETE
Please copy your license to «/opt/thinstuff/rdpserver/licenses»
Default configuration: you can connect to this host with your RDP
client. For server management please connect to this host
using the https protocol (e.g. https://localhost). By default
only the user root has access to the management interface.
Please see the documentation at «/opt/thinstuff/rdpserver/doc»
for further setup and configuration instructions.

На этом процесс установки заканчивается. Для управления сервером необходимо в браузере открыть адрес https://localhost, если устанавливали на локальную машину, а также можно использовать ip-адрес или имя компьютера, при удаленной установке. В данной статье ставилось все на локальном, потому его ip-адрес использовать и будем.
Кратко о получившемся

LX Server устанавливается только в директорию /opt/thinstuff/rdpserver. Установка в другую директорию не поддерживается. Это позволяет гарантировать, что будет установлена только одна копию сервера. LX Server содержит все библиотеки, необходимые для успешного запуска, в своей директории, что позволяет обойтись без необходимости установки каки-либо дополнительных приложений.
Настройка и Администрирование

Поскольку при установке сервера мы решили сразу его и запустить, то он уже работает. Но все же хотелось бы как-то управлять им и в дальнейшем. Для этого предоставляется скрипт для Thinstuff LX Server, находящийся в файле /opt/thinstuff/rdpserver/scripts/rdp-server.init.d-template, который необходимо установить. Дальнейшие шаги будут немного отличаться для различных дистрибутивов, но для основных достаточно будет проделать следующее:

cp /opt/thinstuff/rdpserver/scripts/rdp- server.init.d-template \
/etc/init.d/rdp-server

/usr/lib/lsb/install_initd /etc/init.d/rdp-server

Также, для дальнейшей работы представляют интерес следующие скрипты и директории:

/opt/thinstuff/rdpserver/scripts/startall.sh Запустить сервер.
/opt/thinstuff/rdpserver/scripts/stopall.sh Остановить сервер.
/opt/thinstuff/rdpserver/scripts/init.sh Перезапустить сервер, действует так же, как остановка и последующий запуск.
/opt/thinstuff/rdpserver/licenses/ В этой директории содержатся все текущие лицензии. Лицензии должно храниться только в этом месте; установить лицензию можно простым копированием или перемещением в это место. И для установки или удаления лицензии не требуется перезапускать сервер.

LX Server администрируется и настраивается через веб-интерфейс. Итак, попробуем:

[]

Для входа необходимо ввести следующие данные:

Login — root Password — <пароль пользователя root>
Интерфейс

Интерфейс состоит из четырех частей.

Server StatusПозволяет быстро определить существующие проблемы.
SessionsПоказывает, какие пользователи используют сервисы, и позволяет управлять ими.
RightsПозволяет настроить права доступа к веб-интерфейсу.
SettingsЗдесь можно настроить параметры для терминального сервера и сессий.

Предлагаю пройтись слегка по выше перечисленным пунктам и посмотреть, что они из себя представляют.

Server Status

Server Health

[]

В этом разделе можно получить общее представление о статусе терминального сервера. Для лучшего понимания статус подсвечивается, при возникновении проблем будет показано статусное сообщение.

Существует четыре различных уровня статуса:

Running (зеленый) — Все работает без проблем.

Warning (желтый) — Сервер работает, но один или несколько компонентов испытывают сложности. Это позволяет отслеживать состояние сервера и определить временная ли это проблема или необходимо модернизировать сервер. Пробемы включают:

Центральный процессор, память или другие ресурсы достигли критической точки.

Один или несколько компонентов, но не все, сообщают об ошибках во время операций.

Critical (красный) — Проблемы, подобные описанным в Warning, но они касаются всехрезервных и нерезервных компонентов.

Error (красный) — Один или несколько компонентов не работоспособны и сервер больше не дееспособен. Необходимо перезапустить терминальный сервер.

License Info

Во втором разделе секции отображается информация о ваших текущих лицензиях. Статус лицензий обозначается также цветами, значение которых мы вкратце и опишем:

Valid (зеленый) — Лицензия на данный момент действительна.

Grace (желтый) — Лицензия существует, но срок действия ее истечет в скором времени.

Invalid (красный) — Может иметь несколько причин (неверный hardware id , неверный файл лицензии…)

[]

Sessions

[]

В этой секции отображается список всех активных сессий и подключений к терминальному серверу. На данный момент у меня подключений нет, как видите. Каждая сессия может иметь ни одного, одно или больше подключений.

Rights

Пользователи

[]

Вебсайт и терминальный сервер используют системных пользователей и их паролями. От себя могу сказать, что при тестовой установке на SLES 10, учетные записи пользователей на котором хранятся в LDAP, все эти учетные записи были совершенно прозрачно определены, мне не пришлось вводить какие-либо данные для подключения к серверу каталогов. Список пользователей синхронизируется с системным каждые несколько секунд, потому при добавлении нового пользователя он сможет в скором времени приступить к работе.

Здесь же можно установить права для конкретного пользователя.

[]

Группы

[]

Список групп подобен списку пользователей. Он также синхронизируется с системным списком групп каждые несколько секунд. Также можно изменить права для конкретной группы, кликнув на Rights.

Settings

Эта секция позволяет настроить различные аспекты поведения LX Server: от интервала портов до различной оптимизации ЦП и пропускной способности. Существует два вида настроек:

Global Settings

Действуют глобально на весь сервер. Включают в себя в том числе и номер порта, который будет слушать сервер RDP.

Profile Settings

Они действуют только на конкретную сессию или подключение. Каждая сессия или подключение работает под конкретным профилем, и различные профили могут разные значения для этих настроек.

Количество настроек, которые будут отображаться, зависит от уровня просмотра, котрых существует три:

Level 0 (Standard) — Содержит только часто используемые настройки.
Level 1 (Advanced) — Содержит настройки, присутствующие в Level 0 и дополнительные настройки, контролирующие поведение сервера.
Level 2 (Expert) — Содержит все настройки.

[]

Global Settings

Это настройки, необходимые серверы во время запуска.

Profiles

Часто бывает необходимо указать настройки для конкретного пользователя, подключенного к серверу, в зависимости от того оборудования, которое этот пользователь имеет. Для обеспечения этой возможности у терминального сервера существует концепция профилей. Каждый профиль хранит набор значений настроек, и когда пользователь подключается к серверу, этот профиль выбирается. Количество необходимых профилей зависит от конкретного случая, но, в основном, создается один профиль для каждой группы пользователей, которым необходимы различные настройки.

Settings

[]

Используя Мастер Настроек наиболее общие установки легким способом.

Advanced Settings

В этой секции вы можете как изменить настройки профиля, так и управлять этими профилями.

[]

Поскольку я не вижу смысла в данном документе описывать все подробности всех вариантов настроек, тем более что они могут сильно зависить от конкретных требований, то ограничиваюсь кратким описанием. На сайте Thinstuff выложена достаточно подробная и понятная документация. Она, правда, на английском языке, но особых сложностей в тексте нет, потому вполне понятна. Ссылки на документацию смотрите в конце этого руководства.
Подключение

Теперь, когда практически все готово, можно попробовать подключиться к серверу. В Linux-клиенте будем использовать для этого Gnome-RDP, в Windows — встроенный клиент RDP. В целом, могу сказать, что в подключении сложности нет никакой, при условии, что все предыдущие шаги проделаны верно. И есть еще один момент, на машине, на которую устанавливали RDP-сервер, не забудьте открыть порты 3389 tcp и 3389 udp.

Итак:

[]

Для начала подключимся к тестовому серверу на этой же машине.

[]

[]

На двух верхним рисунках показаны мои настройки. В принципе, они практически дефолтные.

[]

В открывшемся окне вводим имя пользователя и пароль и…

[]

Получаем Рабочий стол на Рабочем столе.

[]

А тут Opera запущенная на «удаленном Рабочем Столе».

Стоит заменить, что можно входить и под пользователем, вход которого уже выполнен. Работа проходит фактически параллельно. Правда, если попытаться запустить Firefox, который уже был запущен при основном входе, то получится вот что:

[]
Заключение

Честно говоря, опыт использования LX Server у меня не большой. Да и, по большому счету, этот опыт сводится к тестовому использованию его в пределах локальной сети на работе. Поскольку я ставил RDP-сервер на арендованный сервер в дата-центре, то была возможность попробовать поработать через сеть Интернет. С достаточно нормальным подключением, а на работе канал 2 мегабита, работать можно нормально. Если местами и подтормаживает, то не сильно и не критично. Но при выходе в Интернет через телефон с подключением к оператору «Скайлинк» в зоне 1х (если кто не в курсе, скорость до 153 килобит), работа с удаленным сервером не комфортна совершенно. Отображение раочего стола тормозит очень заметно. Правда, я не искал и не пытался настроить сам сервер, возможно и есть варианты, но подсказать на данный момент не могу ничего конкретного.

Мой вердикт будет таковым: достаточно хороший вариант для локальной сети, допустим для сервера 1С. Тем более, что сейчас 1С можно использовать установленным на Linux и в версии терминального сервера от Thinstuff для ОС Linux нет ограничения работоспособности по времени, только по клиентам. В Windows-версии, напомню, ограничение в 14 дней. Хотя и в том, и в другом варианте лицензионным соглашением запрещено использование тестовой версии на производстве.

Использование же подключения к действительно удаленному серверу возможно исключительно при достаточно адекватной скорости подключения к сети Интернет, в любом другом случае возможны проблемы.

Общие команды XenServer

Этот пост скорее для меня самого, но вдруг кому понадобится…

По работе установил в качестве гипервизора Citrix Xenserver, потому что он умеет беспроблемно пробрасывать PCI карты (и PCIe если они работают через PCI/PCIe bridge) в гостевые машины.

У этой системы многие вещи делаются через линукс-консоль. Напишу некоторые тут, чтоб не забыть.

Общие команды линукс

lspci
— выдает список всех PCI устройств, тождественна той же команде в «нормальном» линуксе

lsusb
— выдает список всех USB устройств

nano …
— nano — мелкий встроенный текстовый редактор вместо кривого и непонятного vi
выход Ctrl-X

Общие команды Xen

xe vm-list
— выдает список сконфигурированных виртуалок и их UUID

xe pool-list
— выдает список и UUID пула

xe vm-param-set uuid=… other-config:pci=0/0000:02.00.1,0/0000:02.00.2,…
— проброс устройств в виртуалку

xe vm-param-set uuid=… other-config:pci
— с пустым параметром other-config:pci сбрасывает все пробросы к данной виртуалке

Отключение PCI устройств от хоста

Для корректной работы проброса и старта виртуалок необходимо запретить хосту находить пробрасываемые устройства. У хоста этим занимается драйвер pciback. Для запрета их нужно внести в конфиг-файл на хосте.

1. Редактируем конфиг
nano /boot/extlinux.conf

Добавляем в файле в строке в блоке «label xe», начинающейся на «append» в конце перед «— /boot/initrd-…» данные в следующем виде:
pciback.hide=(04:00.0)(04:00.1)
перечисляем все устройства, которые пробрасываются в виртуалки (полностью со всеми подфункциями!)

2. Выполняем команду (пока не знаю зачем…)
extlinux -i /boot

3. Перезагружаем хост
reboot -n

Размер памяти виртуалки

xe vm-param-set uuid=… memory-static-min=1024MiB
— по умолчанию виртуалка с Win7 не может имень меньше 2GB памяти, эта команда корректирует нижний предел

Автостарт

Автостарт для виртуалок при старте сервера:

1. Нужно установить флаг у пула
xe pool-param-set uuid=… other-config:auto_poweron=true

2. Нужно установить флаг у всех виртуалок
xe vm-param-set uuid=… other-config:auto_poweron=true

Спасибо.

Автозапуск виртуальных машин Xenserver 6.5

Многие пользователи платформы Citrix XenServer были несколько удивлены, когда в шестой версии этого продукта заметили, что возможности Auto Start для виртуальных машин были убраны из графического интерфейса консоли управления XenCenter, хотя присутствовали в более ранних версиях.
Сделано это было потому, что механизм автоматического старта виртуальных машин в XenServer конфликтуют с функциями высокой доступности (HA). Однако тем пользователям, которые применяют бесплатное издание XenServer 6 Free Edition, эти возможности, все-таки, нужны.
Настроить автозапуск гостевых машин можно из консоли
1. Определеяем UUID пула, для которого мы хотим включить Auto Start. Для этого выполняем консольную команду на сервере XenServer:
# xe pool-list
uuid ( RO) : 8a3b99c9-c4e9-802c-1298-794d939fb999
2. Разрешаем автостарт виртуальных машин на уровне пула с найденным UUID командой:
# xe pool-param-set uuid=8a3b99c9-c4e9-802c-1298-794d939fb999 other-config:auto_poweron=true
Теперь включаем автостарт на уровне виртуальных машин, для чего:
3. Выполняем команду для получения UUID виртуальной машины:
# xe vm-list
uuid ( RO) : 021fe476-dc06-23a7-b60e-092a3c286f70
name-label ( RW): VM
power-state ( RO): running
4. И для каждой виртуальной машины с найденным UUID включаем автостарт:
# xe vm-param-set uuid=021fe476-dc06-23a7-b60e-092a3c286f70 other-config:auto_poweron=true

Спасибо все работает.

usbreset + smsd_monitoring huawei 1550 + smstools

script usbreset

usbreset -- send a USB port reset to a USB device
 *
 * Compile using: gcc -o usbreset usbreset.c
 *
 *
 * */
#include <stdio.h>
#include <unistd.h>
#include <fcntl.h>
#include <errno.h>
#include <sys/ioctl.h>

#include <linux/usbdevice_fs.h>


int main(int argc, char **argv)
{
	const char *filename;
	int fd;
	int rc;

	if (argc != 2) {
		fprintf(stderr, "Usage: usbreset device-filename\n");
		return 1;
	}
	filename = argv[1];

	fd = open(filename, O_WRONLY);
	if (fd < 0) {
		perror("Error opening output file");
		return 1;
	}

	printf("Resetting USB device %s\n", filename);
	rc = ioctl(fd, USBDEVFS_RESET, 0);
	if (rc < 0) {
		perror("Error in ioctl");
		return 1;
	}
	printf("Reset successful\n");

	close(fd);
	return 0;
}

 

Компилируем файл с помощью любого компилятора C (cc/gcc) командой вида gcc usbreset.c -o usbreset (установить компилятор можно командой apt-get install gcc) , получаем исполняемый файл usbreset.
Даём ему права на выполнение chmod +x usbreset.
Программа usbreset оперирует не с сетевыми интерфейсами, а с устройствами, поэтому с помощью lsusb узнаём необходимые параметры нашего модема.
Выдача lsusb содержит строки вида:
Код: [Выделить]
Bus 004 Device 002: ID 04e8:60a6 Huawey e1550
Конкретно для этого девайса запуск usbreset будет таким:
Код: [Выделить]
./usbreset /dev/bus/usb/004/002
Если есть трудности с определением устройства можно выполнить lsusb -v, которая даёт более развёрнутый ответ и посмотреть там.

И, наконец, добавим в /etc/crontab мониторинг подключения и reset модема при обрыве связи:
Спойлер: моя запись в /etc/crontab (кликните для показа/скрытия)
* * * * * root ping -c 1 8.8.8.8 || ping -c 1 213.87.1.1 || ping -c 1 212. || ./home/leo/bin/usbreset /dev/bus/usb/001/002
т.е. если не проходит пинг ни до одного из указанных ip-адресов — сбросить устройство при помощи программы usbreset.
Внимание! В /etc/network/interfaces для интерфейса модема обязательно должно быть прописано allow-hotplug eth1 (у меня он называется eth1), иначе он не будет автоматически подниматься после сброса.

если случается так что самопроизвольно меняется путь модема (например был /dev/bus/usb/001/002, а стал /dev/bus/usb/001/004), то можно сделать следующее: создать bash-скрипт, с предложенным ниже содержанием и вместо предложенной выше строчки в crontab поместить его.
Код: [Выделить]
#!/bin/bash
d1=`lsusb | grep «1076:8002» | awk ‘{print $2}’`
d2=`lsusb | grep «1076:8002» | awk ‘{print $4}’ | sed ‘s/:/\ /g’`
/bin/ping -c 1 8.8.8.8 || /bin/ping -c 1 8.8.4.4 || /var/script/usbreset /dev/bus/usb/$d1/$d2
Здесь «1076:8002» — ven dev модема, для вашего модема значение будет другим.
Естественно всё что используется в скрипте должно быть установлено. 🙂

usbreset.tar.gz

script smsd_monitoring

cat /etc/smsd_monitoring
#!/bin/bash
rm /root/buffer_sms_file
date=`date`
tail -n5 /var/log/smstools/smsd.log > /root/buffer_sms_file
cat /root/buffer_sms_file | grep "Error: Modem is not registered to the network"
if [ $? -eq 0 ]; then
        /root/usbreset /dev/bus/usb/004/$(lsusb | grep Huawei | cut -d ' ' -f 4 | tr ':' ' '| sed -e '/^$/d' | head -c 3)
#       /root/reboot_modem_soft
        /etc/init.d/smstools restart
#        tar cvfz /var/log/smstools/smsd.log /var/log/smstools/sms_erlog_$date.log
#        shutdown -rf now
        fi

cat /root/buffer_sms_file | grep "Error: registration is denied"
if [ $? -eq 0 ]; then
        /root/usbreset /dev/bus/usb/004/$(lsusb | grep Huawei | cut -d ' ' -f 4 | tr ':' ' '| sed -e '/^$/d' | head -c 3)
#       /root/reboot_modem_soft
        /etc/init.d/smstools restart
#        tar cvfz /var/log/smstools/smsd.log /var/log/smstools/sms_erlog_$date.log
#        shutdown -rf now
        fi

cat /root/buffer_sms_file | grep "Modem handler 0 terminated abnormally"
if [ $? -eq 0 ]; then
        /root/usbreset /dev/bus/usb/004/$(lsusb | grep Huawei | cut -d ' ' -f 4 | tr ':' ' '| sed -e '/^$/d' | head -c 3)
#       /root/reboot_modem_soft
        /etc/init.d/smstools restart
#        tar cvfz /var/log/smstools/smsd.log /var/log/smstools/sms_erlog_$date.log
#        shutdown -rf now
        fi

cat /root/buffer_sms_file | grep "write_to_modem: error 5: Input/output error"
if [ $? -eq 0 ]; then
        /root/usbreset /dev/bus/usb/004/$(lsusb | grep Huawei | cut -d ' ' -f 4 | tr ':' ' '| sed -e '/^$/d' | head -c 3)
#       /root/reboot_modem_soft
        /etc/init.d/smstools restart
#        tar cvfz /var/log/smstools/smsd.log /var/log/smstools/sms_erlog_$date.log
#        shutdown -rf now
        fi

cat /root/buffer_sms_file | grep "Couldn't open serial port"
if [ $? -eq 0 ]; then
        /root/usbreset /dev/bus/usb/004/$(lsusb | grep Huawei | cut -d ' ' -f 4 | tr ':' ' '| sed -e '/^$/d' | head -c 3)
#       /root/reboot_modem_soft
        /etc/init.d/smstools restart
#        tar cvfz /var/log/smstools/smsd.log /var/log/smstools/sms_erlog_$date.log
#        shutdown -rf now
        fi

 

Спасибо 1
Спасибо2

samba conf 3.6

Samba security user config
Version: 2:3.6.6-2~bpo60+1

cat /etc/samba/smb.conf
#
# Sample configuration file for the Samba suite for Debian GNU/Linux.
#
#
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which
# are not shown in this example
#
# Some options that are often worth tuning have been included as
# commented-out examples in this file.
#  - When such options are commented with ";", the proposed setting
#    differs from the default Samba behaviour
#  - When commented with "#", the proposed setting is the default
#    behaviour of Samba but the option is considered important
#    enough to be mentioned here
#
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic
# errors.
# A well-established practice is to name the original file
# "smb.conf.master" and create the "real" config file with
# testparm -s smb.conf.master >smb.conf
# This minimizes the size of the really used smb.conf file
# which, according to the Samba Team, impacts performance
# However, use this with caution if your smb.conf file contains nested
# "include" statements. See Debian bug #483187 for a case
# where using a master file is not a good idea.
#

#======================= Global Settings =======================

[global]

## Browsing/Identification ###
max protocol = SMB2

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = WORKGROUP

# server string is the equivalent of the NT Description field
   server string =

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
#   wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
   dns proxy = no

# What naming service and in what order should we use to resolve host names
# to IP addresses
;   name resolve order = lmhosts host wins bcast

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
;   interfaces = 127.0.0.0/8 eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself.  However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
;   bind interfaces only = yes



#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
   log file = /var/log/samba/log.%m

# Cap the size of the individual log files (in KiB).
   max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
#   syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.
   syslog = 0

# Do something sensible when Samba crashes: mail the admin a backtrace
   panic action = /usr/share/samba/panic-action %d


####### Authentication #######

# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/ServerType.html
# in the samba-doc package for details.
   security = share

# You may wish to use password encryption.  See the section on
# 'encrypt passwords' in the smb.conf(5) manpage before enabling.
   encrypt passwords = true

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using.
   passdb backend = tdbsam

   obey pam restrictions = yes

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
   unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian Sarge).
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
   pam password change = yes

# This option controls how unsuccessful authentication attempts are mapped
# to anonymous connections
   map to guest = bad user

########## Domains ###########

# Is this machine able to authenticate users. Both PDC and BDC
# must have this setting enabled. If you are the BDC you must
# change the 'domain master' setting to no
#
;   domain logons = yes
#
# The following setting only takes effect if 'domain logons' is set
# It specifies the location of the user's profile directory
# from the client point of view)
# The following required a [profiles] share to be setup on the
# samba server (see below)
;   logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home directory
# (this is Samba's default)
#   logon path = \\%N\%U\profile

# The following setting only takes effect if 'domain logons' is set
# It specifies the location of a user's home directory (from the client
# point of view)
;   logon drive = H:
#   logon home = \\%N\%U

# The following setting only takes effect if 'domain logons' is set
# It specifies the script to run during logon. The script must be stored
# in the [netlogon] share
# NOTE: Must be store in 'DOS' file format convention
;   logon script = logon.cmd

# This allows Unix users to be created on the domain controller via the SAMR
# RPC pipe.  The example command creates a user account with a disabled Unix
# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

# This allows machine accounts to be created on the domain controller via the
# SAMR RPC pipe.
# The following assumes a "machines" group exists on the system
; add machine script  = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u

# This allows Unix groups to be created on the domain controller via the SAMR
# RPC pipe.
; add group script = /usr/sbin/addgroup --force-badname %g

########## Printing ##########

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
#   load printers = yes

# lpr(ng) printing. You may wish to override the location of the
# printcap file
;   printing = bsd
;   printcap name = /etc/printcap

# CUPS printing.  See also the cupsaddsmb(8) manpage in the
# cupsys-client package.
;   printing = cups
;   printcap name = cups

############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /home/samba/etc/smb.conf.%m

# Most people will find that this option gives better performance.
# See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/speed.html
# for details
# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192
#   socket options = TCP_NODELAY

# The following parameter is useful only if you have the linpopup package
# installed. The samba maintainer and the linpopup maintainer are
# working to ease installation and configuration of linpopup and samba.
;   message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &

# Domain Master specifies Samba to be the Domain Master Browser. If this
# machine will be configured as a BDC (a secondary logon server), you
# must set this to 'no'; otherwise, the default behavior is recommended.
#   domain master = auto

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   idmap uid = 10000-20000
;   idmap gid = 10000-20000
;   template shell = /bin/bash

# The following was the default behaviour in sarge,
# but samba upstream reverted the default because it might induce
# performance issues in large organizations.
# See Debian bug #368251 for some of the consequences of *not*
# having this setting and smb.conf(5) for details.
;   winbind enum groups = yes
;   winbind enum users = yes

# Setup usershare options to enable non-root users to share folders
# with the net usershare command.

# Maximum number of usershare. 0 (default) means that usershare is disabled.
;   usershare max shares = 100

# Allow users who've been granted usershare privileges to create
# public shares, not just authenticated ones
   usershare allow guests = yes

#======================= Share Definitions =======================

# [homes]
#   comment = Home Directories
#   browseable = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
#   read only = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
#   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
#   directory mask = 0700

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.
# The following parameter makes sure that only "username" can connect
# to \\server\username
# This might need tweaking when using external authentication schemes
#   valid users = %S

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

;[printers]
;   comment = All Printers
;   browseable = no
;   path = /var/spool/samba
;   printable = yes
;   guest ok = no
;   read only = yes
;   create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
;[print$]
;   comment = Printer Drivers
;   path = /var/lib/samba/printers
;   browseable = yes
;   read only = yes
;   guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# You may need to replace 'lpadmin' with the name of the group your
# admin users are members of.
# Please note that you also need to set appropriate Unix permissions
# to the drivers directory for these users to have write rights in it
;   write list = root, @lpadmin

# A sample share for sharing your CD-ROM with others.
;[cdrom]
;   comment = Samba server's CD-ROM
;   read only = yes
;   locking = no
;   path = /cdrom
;   guest ok = yes

# The next two parameters show how to auto-mount a CD-ROM when the
#       cdrom share is accesed. For this to work /etc/fstab must contain
#       an entry like this:
#
#       /dev/scd0   /cdrom  iso9660 defaults,noauto,ro,user   0 0
#
# The CD-ROM gets unmounted automatically after the connection to the
#
# If you don't want to use auto-mounting/unmounting make sure the CD
#       is mounted on /cdrom
#
;   preexec = /bin/mount /cdrom
;   postexec = /bin/umount /cdrom

[0000000000]
path = /mnt/0000000000
guest ok = Yes
guest only = no
writeable = Yes
read only = no
create mask = 0777
directory mask = 0777
force user = user
force group = users
oplocks = no

[Consultant]
path = /mnt/consultant
guest ok = Yes
guest only = no
writeable = Yes
read only = no
create mask = 0777
directory mask = 0777
force user = user
force group = users

[SprutDataBase]
path = /mnt/SprutDataBase
guest ok = Yes
guest only = no
writeable = Yes
read only = no
create mask = 0777
directory mask = 0777
force user = user
force group = users

 

cat /etc/fstab
/dev/md0 /mnt ext4 defaults 1 2

Client
#//192.168.0.167/0000000000 /media/0 cifs auto,rw,file_mode=0666,dir_mode=0777,username=user,password=,iocharset=utf8 0 0

Weekly report

cat /etc/weekly_report_usa
#!/bin/bash
if [ -d /mnt/0000000000/smsgate/ ]; then
        echo "Existing buffer directory" | tee /var/log/mail.log
else
        mkdir  -p -m 777 /mnt/0000000000/smsgate/
        echo "Created buffer created" | tee /var/log/mail.log
fi
echo "Send mail to dmurrdj@gmail.com" | tee /var/log/mail.log
echo "" | mutt -x -s "Weekly Report UTS" -a /mnt/0000000000/smsgate/WeeklyReport.xls -- dxxxxxj@gmail.com

echo "Remove report.XLS file"
rm /mnt/0000000000/smsgate/WeeklyReport.xls

 

скрипт переключения с основного канала на резервный mikrotik router os6

Имеем 2 канала WAN, основной оптика — статика, 3g модем huawei e392(мегафон) — динамика tele2.
Прошивка родная мегафоновская, только снимал блокировку на провайдера.

 / ip route print detail where comment =ISP1
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
 0 A S  ;;; ISP1
        dst-address=0.0.0.0/0 gateway=212.118.55.17 gateway-status=212.118.55.17 reachable via  ether1-gateway
        check-gateway=ping distance=1 scope=30 target-scope=10


/interface ppp-client print
Flags: X - disabled, R - running

 0 X  ;;; ISP2
      name="ppp-tele2" max-mtu=1500 max-mru=1500 mrru=disabled port=usb3 data-channel=0 info-channel=0
      apn="internet.tele2.ru" pin="" user="" password="" profile=default phone="" dial-command="ATDT"
      modem-init="" null-modem=no dial-on-demand=no add-default-route=yes default-route-distance=2
      use-peer-dns=yes keepalive-timeout=0 allow=pap,chap,mschap1,mschap2

 

Вместо netwatch используем скрипт, который с помощью шедулера надо запускать, к примеру, каждые 10-30 секунд.

#Name:          backup3G
#Version:       1.0
#Created:       Gerasimov A. with my fix
#Web:           http://papa-admin.ru
#Date:          01.2014
#Description:  failover for 3G modem
#
:local PingCount 3;

:local InterfaceWan ether1-gateway;
:local Interface3G ppp-tele2;
:local CheckIp 193.0.14.129;
:local Use3G false;

:local WANstatus [/interface get [/interface find name="$InterfaceWan"] running];
:if ($WANstatus=false) do={
	:set Use3G true;
} else {
	:local CheckMainISP [/ping $CheckIp count=$PingCount interface=$InterfaceWan];
	:if ($CheckMainISP=3) do={
		:set Use3G false;
	} else {
		:set Use3G true;
	}
}
:local 3Gstatus [/interface get [/interface find name="$Interface3G"] running];
:if ($Use3G=true) do={
	if ($3Gstatus=false) do={
		/interface enable [find name="$Interface3G"];
		:log warning "Set routes to 3G ISP";
	}
} else {
	:if ($3Gstatus=true) do={
		/interface disable [find name="$Interface3G"];
		:log warning "Set routes to Main ISP";
	}
}

 

Немного пояснений:

InterfaceWan — основной интерфейс
Interface3G — резервный интерфейс 3G модема
CheckIP — ip адрес, пинг которого проверяется для работоспособности основного интерфейса, и маршрутизация которого настроена через основной интерфейс.

Чтобы прописать скрипт и шедулер подключаемся к маршрутизатору по ssh или через WinBox и New Terminal и вводим:

/system script
add name=backup3G policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source="#Name:          backup3G\r\
    \n#Version:       1.0\r\
    \n#Created:       Gerasimov A. with my fix\r\
    \n#Web:           http://papa-admin.ru\r\
    \n#Date:          01.2014\r\
    \n#Description:  failover for 3G modem\r\
    \n#\r\
    \n:local PingCount 3;\r\
    \n\r\
    \n:local InterfaceWan ether1-gateway;\r\
    \n:local Interface3G ppp-tele2;\r\
    \n:local CheckIp 193.0.14.129;\r\
    \n:local Use3G false;\r\
    \n\r\
    \n:local WANstatus [/interface get [/interface find name=\"\$InterfaceWan\
    \"] running];\r\
    \n:if (\$WANstatus=false) do={\r\
    \n\t:set Use3G true;\r\
    \n} else {\r\
    \n\t:local CheckMainISP [/ping \$CheckIp count=\$PingCount interface=\$InterfaceWan];\r\
    \n\t:if (\$CheckMainISP=3) do={\r\
    \n\t\t:set Use3G false;\r\
    \n\t} else {\r\
    \n\t\t:set Use3G true;\r\
    \n\t}\r\
    \n}\r\
    \n:local 3Gstatus [/interface get [/interface find name=\"\$Interface3G\"]\
    \_running];\r\
    \n:if (\$Use3G=true) do={\r\
    \n\tif (\$3Gstatus=false) do={\r\
    \n\t\t/interface enable [find name=\"\$Interface3G\"];\r\
    \n\t\t:log warning \"Set routes to 3G ISP\";\r\
    \n\t}\r\
    \n} else {\r\
    \n\t:if (\$3Gstatus=true) do={\r\
    \n\t\t/interface disable [find name=\"\$Interface3G\"];\r\
    \n\t\t:log warning \"Set routes to Main ISP\";\r\
    \n\t}\r\
    \n}\r\
    \n"

 

/system scheduler add interval=10s name=checkISP on-event=backup3G

 

Я поставил чтобы скрипт запускался каждые 10 секунд.
Работоспособность проверена на 2011UiAS-2HnD и ROS 6.32.3

Спасибо. + Не забыть dial-on-demand=no add-default-route=yes default-route-distance=2 на модем.

mikrotik backup script on one host

Вешаем скрипт на сервер, прописываем пути, пользователя Mikrotik и сертификаты ssh.

#!/bin/bash
routers=( 192.168.0.1 192.168.3.1 192.168.4.1 )
backupdir="/home/backup/mikrotik"
privatekey="/root/.ssh/id_dsa"
login="admin"
passwd="pa$Sw0rd"
fulldir="${backupdir}/`date +%Y`/`date +%m`/`date +%d`"

for r in ${routers[@]}; do
    cmd_backup="/system backup save name=${r}.backup"
    ssh ${login}@$r -i $privatekey "${cmd_backup}" > /dev/null
    cmd_backup="/export file=${r}"
    ssh ${login}@$r -i $privatekey "${cmd_backup}" > /dev/null
    sleep 5
    mkdir -p $fulldir
    wget -qP $fulldir ftp://${login}:${passwd}@${r}/${r}.backup
    wget -qP $fulldir ftp://${login}:${passwd}@${r}/${r}.rsc
    ssh ${login}@$r -i $privatekey "/file remove \"${r}.backup\""
    ssh ${login}@$r -i $privatekey "/file remove \"${r}.rsc\""
done

 

Спасибо