Записи с Меткой ‘ linux

samba conf 3.6

Samba security user config
Version: 2:3.6.6-2~bpo60+1

cat /etc/samba/smb.conf
#
# Sample configuration file for the Samba suite for Debian GNU/Linux.
#
#
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which
# are not shown in this example
#
# Some options that are often worth tuning have been included as
# commented-out examples in this file.
#  - When such options are commented with ";", the proposed setting
#    differs from the default Samba behaviour
#  - When commented with "#", the proposed setting is the default
#    behaviour of Samba but the option is considered important
#    enough to be mentioned here
#
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic
# errors.
# A well-established practice is to name the original file
# "smb.conf.master" and create the "real" config file with
# testparm -s smb.conf.master >smb.conf
# This minimizes the size of the really used smb.conf file
# which, according to the Samba Team, impacts performance
# However, use this with caution if your smb.conf file contains nested
# "include" statements. See Debian bug #483187 for a case
# where using a master file is not a good idea.
#

#======================= Global Settings =======================

[global]

## Browsing/Identification ###
max protocol = SMB2

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = WORKGROUP

# server string is the equivalent of the NT Description field
   server string =

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
#   wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
   dns proxy = no

# What naming service and in what order should we use to resolve host names
# to IP addresses
;   name resolve order = lmhosts host wins bcast

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
;   interfaces = 127.0.0.0/8 eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself.  However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
;   bind interfaces only = yes



#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
   log file = /var/log/samba/log.%m

# Cap the size of the individual log files (in KiB).
   max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
#   syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.
   syslog = 0

# Do something sensible when Samba crashes: mail the admin a backtrace
   panic action = /usr/share/samba/panic-action %d


####### Authentication #######

# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/ServerType.html
# in the samba-doc package for details.
   security = share

# You may wish to use password encryption.  See the section on
# 'encrypt passwords' in the smb.conf(5) manpage before enabling.
   encrypt passwords = true

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using.
   passdb backend = tdbsam

   obey pam restrictions = yes

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
   unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian Sarge).
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
   pam password change = yes

# This option controls how unsuccessful authentication attempts are mapped
# to anonymous connections
   map to guest = bad user

########## Domains ###########

# Is this machine able to authenticate users. Both PDC and BDC
# must have this setting enabled. If you are the BDC you must
# change the 'domain master' setting to no
#
;   domain logons = yes
#
# The following setting only takes effect if 'domain logons' is set
# It specifies the location of the user's profile directory
# from the client point of view)
# The following required a [profiles] share to be setup on the
# samba server (see below)
;   logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home directory
# (this is Samba's default)
#   logon path = \\%N\%U\profile

# The following setting only takes effect if 'domain logons' is set
# It specifies the location of a user's home directory (from the client
# point of view)
;   logon drive = H:
#   logon home = \\%N\%U

# The following setting only takes effect if 'domain logons' is set
# It specifies the script to run during logon. The script must be stored
# in the [netlogon] share
# NOTE: Must be store in 'DOS' file format convention
;   logon script = logon.cmd

# This allows Unix users to be created on the domain controller via the SAMR
# RPC pipe.  The example command creates a user account with a disabled Unix
# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

# This allows machine accounts to be created on the domain controller via the
# SAMR RPC pipe.
# The following assumes a "machines" group exists on the system
; add machine script  = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u

# This allows Unix groups to be created on the domain controller via the SAMR
# RPC pipe.
; add group script = /usr/sbin/addgroup --force-badname %g

########## Printing ##########

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
#   load printers = yes

# lpr(ng) printing. You may wish to override the location of the
# printcap file
;   printing = bsd
;   printcap name = /etc/printcap

# CUPS printing.  See also the cupsaddsmb(8) manpage in the
# cupsys-client package.
;   printing = cups
;   printcap name = cups

############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /home/samba/etc/smb.conf.%m

# Most people will find that this option gives better performance.
# See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/speed.html
# for details
# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192
#   socket options = TCP_NODELAY

# The following parameter is useful only if you have the linpopup package
# installed. The samba maintainer and the linpopup maintainer are
# working to ease installation and configuration of linpopup and samba.
;   message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &

# Domain Master specifies Samba to be the Domain Master Browser. If this
# machine will be configured as a BDC (a secondary logon server), you
# must set this to 'no'; otherwise, the default behavior is recommended.
#   domain master = auto

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   idmap uid = 10000-20000
;   idmap gid = 10000-20000
;   template shell = /bin/bash

# The following was the default behaviour in sarge,
# but samba upstream reverted the default because it might induce
# performance issues in large organizations.
# See Debian bug #368251 for some of the consequences of *not*
# having this setting and smb.conf(5) for details.
;   winbind enum groups = yes
;   winbind enum users = yes

# Setup usershare options to enable non-root users to share folders
# with the net usershare command.

# Maximum number of usershare. 0 (default) means that usershare is disabled.
;   usershare max shares = 100

# Allow users who've been granted usershare privileges to create
# public shares, not just authenticated ones
   usershare allow guests = yes

#======================= Share Definitions =======================

# [homes]
#   comment = Home Directories
#   browseable = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
#   read only = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
#   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
#   directory mask = 0700

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.
# The following parameter makes sure that only "username" can connect
# to \\server\username
# This might need tweaking when using external authentication schemes
#   valid users = %S

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

;[printers]
;   comment = All Printers
;   browseable = no
;   path = /var/spool/samba
;   printable = yes
;   guest ok = no
;   read only = yes
;   create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
;[print$]
;   comment = Printer Drivers
;   path = /var/lib/samba/printers
;   browseable = yes
;   read only = yes
;   guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# You may need to replace 'lpadmin' with the name of the group your
# admin users are members of.
# Please note that you also need to set appropriate Unix permissions
# to the drivers directory for these users to have write rights in it
;   write list = root, @lpadmin

# A sample share for sharing your CD-ROM with others.
;[cdrom]
;   comment = Samba server's CD-ROM
;   read only = yes
;   locking = no
;   path = /cdrom
;   guest ok = yes

# The next two parameters show how to auto-mount a CD-ROM when the
#       cdrom share is accesed. For this to work /etc/fstab must contain
#       an entry like this:
#
#       /dev/scd0   /cdrom  iso9660 defaults,noauto,ro,user   0 0
#
# The CD-ROM gets unmounted automatically after the connection to the
#
# If you don't want to use auto-mounting/unmounting make sure the CD
#       is mounted on /cdrom
#
;   preexec = /bin/mount /cdrom
;   postexec = /bin/umount /cdrom

[0000000000]
path = /mnt/0000000000
guest ok = Yes
guest only = no
writeable = Yes
read only = no
create mask = 0777
directory mask = 0777
force user = user
force group = users
oplocks = no

[Consultant]
path = /mnt/consultant
guest ok = Yes
guest only = no
writeable = Yes
read only = no
create mask = 0777
directory mask = 0777
force user = user
force group = users

[SprutDataBase]
path = /mnt/SprutDataBase
guest ok = Yes
guest only = no
writeable = Yes
read only = no
create mask = 0777
directory mask = 0777
force user = user
force group = users

 

cat /etc/fstab
/dev/md0 /mnt ext4 defaults 1 2

Client
#//192.168.0.167/0000000000 /media/0 cifs auto,rw,file_mode=0666,dir_mode=0777,username=user,password=,iocharset=utf8 0 0

Weekly report

cat /etc/weekly_report_usa
#!/bin/bash
if [ -d /mnt/0000000000/smsgate/ ]; then
        echo "Existing buffer directory" | tee /var/log/mail.log
else
        mkdir  -p -m 777 /mnt/0000000000/smsgate/
        echo "Created buffer created" | tee /var/log/mail.log
fi
echo "Send mail to dmurrdj@gmail.com" | tee /var/log/mail.log
echo "" | mutt -x -s "Weekly Report UTS" -a /mnt/0000000000/smsgate/WeeklyReport.xls -- dxxxxxj@gmail.com

echo "Remove report.XLS file"
rm /mnt/0000000000/smsgate/WeeklyReport.xls

 

logwatch + ssmtp debian 6

apt-get install logwatch ssmtp

Для дополнительных настроек можно скопировать конфигурацию по-умолчанию и изменить нужные опции:
mkdir /etc/logwatch/conf/
cp /usr/share/logwatch/default.conf/logwatch.conf /etc/logwatch/conf/logwatch.conf
Стандартный файл настроен хорошо прокомментирован и понятен. Но привожу список настроек на которые стоит обратить внимание:

MailTo – указывает на какой адрес отсылать отчёты. Если у вас не настроена почта для root имеет смысл указать необходимый адрес полностью
MailFrom – имя отправителя письма
Print – указывает либо печатать вывод в консоль (YES) либо отправлять отчёт на почту (NO)
Save – позволяет задать путь сохранения отчёта на сервере при необходимости
Archives – при составлении отчёта просматривать архивные файлы логов (типа /var/log/messages.1.gz). Если отчёт генериться за одни день нет смысла включать эту опцию. Также эта опция зависит от режима ротации логов в системе
Range – указывает период за который составляется отчёт (All, Today, Yesterday)
Detail – уровень детализации отчёта
Service = All – запускает анализ логов по всем сервисам определенным в /usr/share/logwatch/scripts/services/
Service = «-eximstats» – дополнительно можно исключить определенные сервисы из набора для анализа

cat /etc/logwatch/conf/logwatch.conf
mailer = "/usr/sbin/sendmail -t"
TmpDir = /tmp
MailFrom = info@uxxxxxk.ru
MailTo = dmurrdj@gmail.com
Save = /root/logwatch
Range = Yesterday
Detail = high

 

 cat /etc/ssmtp/ssmtp.conf
#
# Config file for sSMTP sendmail
#
# The person who gets all mail for userids < 1000
# Make this empty to disable rewriting.
#root=info@uxxxxxk.ru # kto shlet pis'ma
root=info@uxxxxxk.ru

# The place where the mail goes. The actual machine name is required no
# MX records are consulted. Commonly mailhosts are named mail.domain.com
mailhub=smtp.yandex.ru:465

# Where will the mail seem to come from?
#rewriteDomain=

# The full hostname
hostname=ServerSambaTruckstar

# Are users allowed to set their own From: address?
# YES - Allow the user to specify their own From: address
# NO - Use the system generated From: address
#FromLineOverride=YES

UseTLS=Yes
AuthUser=info@uxxxxxk.ru
AuthPass=ksjhdfgkfsdlkhsdklfgjsldkj
FromLineOverride=Yes

 

cat /etc/ssmtp/revaliases
# sSMTP aliases
#
# Format:       local_account:outgoing_address:mailhub
#
# Example: root:your_login@your.domain:mailhub.your.domain[:port]
# where [:port] is an optional port number that defaults to 25.
#for yandex
root:info@uxxxxxxk.ru:smtp.yandex.ru:465

 

Проверим работу logwatch. Отчет должен сформироваться и прийти на почту.

# /etc/cron.daily/00logwatch

скрипт переключения с основного канала на резервный mikrotik router os6

Имеем 2 канала WAN, основной оптика — статика, 3g модем huawei e392(мегафон) — динамика tele2.
Прошивка родная мегафоновская, только снимал блокировку на провайдера.

 / ip route print detail where comment =ISP1
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
 0 A S  ;;; ISP1
        dst-address=0.0.0.0/0 gateway=212.118.55.17 gateway-status=212.118.55.17 reachable via  ether1-gateway
        check-gateway=ping distance=1 scope=30 target-scope=10


/interface ppp-client print
Flags: X - disabled, R - running

 0 X  ;;; ISP2
      name="ppp-tele2" max-mtu=1500 max-mru=1500 mrru=disabled port=usb3 data-channel=0 info-channel=0
      apn="internet.tele2.ru" pin="" user="" password="" profile=default phone="" dial-command="ATDT"
      modem-init="" null-modem=no dial-on-demand=no add-default-route=yes default-route-distance=2
      use-peer-dns=yes keepalive-timeout=0 allow=pap,chap,mschap1,mschap2

 

Вместо netwatch используем скрипт, который с помощью шедулера надо запускать, к примеру, каждые 10-30 секунд.

#Name:          backup3G
#Version:       1.0
#Created:       Gerasimov A. with my fix
#Web:           http://papa-admin.ru
#Date:          01.2014
#Description:  failover for 3G modem
#
:local PingCount 3;

:local InterfaceWan ether1-gateway;
:local Interface3G ppp-tele2;
:local CheckIp 193.0.14.129;
:local Use3G false;

:local WANstatus [/interface get [/interface find name="$InterfaceWan"] running];
:if ($WANstatus=false) do={
	:set Use3G true;
} else {
	:local CheckMainISP [/ping $CheckIp count=$PingCount interface=$InterfaceWan];
	:if ($CheckMainISP=3) do={
		:set Use3G false;
	} else {
		:set Use3G true;
	}
}
:local 3Gstatus [/interface get [/interface find name="$Interface3G"] running];
:if ($Use3G=true) do={
	if ($3Gstatus=false) do={
		/interface enable [find name="$Interface3G"];
		:log warning "Set routes to 3G ISP";
	}
} else {
	:if ($3Gstatus=true) do={
		/interface disable [find name="$Interface3G"];
		:log warning "Set routes to Main ISP";
	}
}

 

Немного пояснений:

InterfaceWan — основной интерфейс
Interface3G — резервный интерфейс 3G модема
CheckIP — ip адрес, пинг которого проверяется для работоспособности основного интерфейса, и маршрутизация которого настроена через основной интерфейс.

Чтобы прописать скрипт и шедулер подключаемся к маршрутизатору по ssh или через WinBox и New Terminal и вводим:

/system script
add name=backup3G policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source="#Name:          backup3G\r\
    \n#Version:       1.0\r\
    \n#Created:       Gerasimov A. with my fix\r\
    \n#Web:           http://papa-admin.ru\r\
    \n#Date:          01.2014\r\
    \n#Description:  failover for 3G modem\r\
    \n#\r\
    \n:local PingCount 3;\r\
    \n\r\
    \n:local InterfaceWan ether1-gateway;\r\
    \n:local Interface3G ppp-tele2;\r\
    \n:local CheckIp 193.0.14.129;\r\
    \n:local Use3G false;\r\
    \n\r\
    \n:local WANstatus [/interface get [/interface find name=\"\$InterfaceWan\
    \"] running];\r\
    \n:if (\$WANstatus=false) do={\r\
    \n\t:set Use3G true;\r\
    \n} else {\r\
    \n\t:local CheckMainISP [/ping \$CheckIp count=\$PingCount interface=\$InterfaceWan];\r\
    \n\t:if (\$CheckMainISP=3) do={\r\
    \n\t\t:set Use3G false;\r\
    \n\t} else {\r\
    \n\t\t:set Use3G true;\r\
    \n\t}\r\
    \n}\r\
    \n:local 3Gstatus [/interface get [/interface find name=\"\$Interface3G\"]\
    \_running];\r\
    \n:if (\$Use3G=true) do={\r\
    \n\tif (\$3Gstatus=false) do={\r\
    \n\t\t/interface enable [find name=\"\$Interface3G\"];\r\
    \n\t\t:log warning \"Set routes to 3G ISP\";\r\
    \n\t}\r\
    \n} else {\r\
    \n\t:if (\$3Gstatus=true) do={\r\
    \n\t\t/interface disable [find name=\"\$Interface3G\"];\r\
    \n\t\t:log warning \"Set routes to Main ISP\";\r\
    \n\t}\r\
    \n}\r\
    \n"

 

/system scheduler add interval=10s name=checkISP on-event=backup3G

 

Я поставил чтобы скрипт запускался каждые 10 секунд.
Работоспособность проверена на 2011UiAS-2HnD и ROS 6.32.3

Спасибо. + Не забыть dial-on-demand=no add-default-route=yes default-route-distance=2 на модем.

mikrotik backup script on one host

Вешаем скрипт на сервер, прописываем пути, пользователя Mikrotik и сертификаты ssh.

#!/bin/bash
routers=( 192.168.0.1 192.168.3.1 192.168.4.1 )
backupdir="/home/backup/mikrotik"
privatekey="/root/.ssh/id_dsa"
login="admin"
passwd="pa$Sw0rd"
fulldir="${backupdir}/`date +%Y`/`date +%m`/`date +%d`"

for r in ${routers[@]}; do
    cmd_backup="/system backup save name=${r}.backup"
    ssh ${login}@$r -i $privatekey "${cmd_backup}" > /dev/null
    cmd_backup="/export file=${r}"
    ssh ${login}@$r -i $privatekey "${cmd_backup}" > /dev/null
    sleep 5
    mkdir -p $fulldir
    wget -qP $fulldir ftp://${login}:${passwd}@${r}/${r}.backup
    wget -qP $fulldir ftp://${login}:${passwd}@${r}/${r}.rsc
    ssh ${login}@$r -i $privatekey "/file remove \"${r}.backup\""
    ssh ${login}@$r -i $privatekey "/file remove \"${r}.rsc\""
done

 

Спасибо

Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again

Фикс простой:
vim /etc/yum.repos.d/epel.repo
И на строке mirrorlist=https заменяем на http.

Спасибо

Xenserver disable ha pool

I use the host-emergency-ha-disable Force=true command I cannot restart the toolstack because
I use a commandfile…

the problem is that after using host-emergency-ha-disable Force=true* the *host-disable enabled=true —multiple
command because it fails with an error «This operation cannot be performed because HA would no longer be guaranteed for this pool…»

It seems that running pool-ha-disable* after *host-emergency-ha-disable works — I hope that it will not
hang at pool-ha-disable if it is an emergency shutdown…

Настройка сети CentOS

Спасибо, чтобы было под рукой

Настройка сетевого адаптера из консоли CentOS

Откройте файл /etc/udev/rules.d/70-persistent-net.rules для изменения имени интерфейса сетевого устройства.

Описание каждого сетевого устройства, в этом файле, выглядит следующим образом :

# PCI device 0x11ab:0x4363 (sky2)
SUBSYSTEM==»net», ACTION==»add», DRIVERS==»?*»,
ATTR{address}==»00:00:00:00:00:00″,ATTR{dev_id}==»0x0″, ATTR{type}==»1″,
KERNEL==»eth*», NAME=»eth0″

Допустим у вас новенький сервер на CentOS, в нем два сетевых адаптера. На сервере установлена CentOS без графического интерфейса, есть только голая консоль. При этом сетевые карты не настроены должным образом.

Задача: Настроить сетевые интерфейсы

Настройки сетевых карт хранятся в файлах:

/etc/sysconfig/network-scripts/ifcfg-eth*

* — за место звездочки ставится номер адаптера

Обычно после установки CentOS в этом файле есть только четыре строчки:

# cat /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=»eth0″
HWADDR=»08:00:27:79:17:85″
NM_CONTROLLED=»yes»
ONBOOT=»no»
Следует дописать в этот файл дополнительные настройки:

# vi /etc/sysconfig/network-scripts/ifcfg-eth*

DEVICE=»eth0″
HWADDR=»08:00:27:79:17:85″
NM_CONTROLLED=»no»
ONBOOT=»yes»

BOOTPROTO=static
GATEWAY=10.168.50.2
IPADDR=10.168.50.45
NETMASK=255.255.255.0
BROADCAST=10.168.50.255
DNS1=10.168.50.1
После конфигурирования интерфейсов перезагрузите сетевую службу:

# service network restart

Это самый быстрый и простой метод настройки сетевых адаптеров. Когда вы будете настраивать интерфейс, обязательно следите за последовательностью строк в файле ifcfg-eth*. Например если записать «GATEWAY=10.168.50.2″ в конце файла, шлюз работать возможно не будет! За место NETMASK=255.255.255.0 можно написать PREFIX=24.

Теперь второй вариант настройки, похожий на первый.

Также открываем файл:

# vi /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=»eth0″
HWADDR=»08:00:27:79:17:85″
NM_CONTROLLED=»no»
ONBOOT=»yes»
GATEWAY=10.168.50.2
IPADDR=10.168.50.45
NETMASK=255.255.255.0
BROADCAST=10.168.50.255
Интерфейс настроен, осталось прописать DNS сервер и шлюз по умолчанию.

Настройка DNS:

# vi /etc/resolv.conf

nameserver 10.168.50.1 //Первичный DNS

nameserver 10.168.50.2 //Вторичный DNS
Настройка шлюза по умолчанию:

# vi /etc/sysconfig/network

GATEWAY=10.168.50.2
или

# vi /etc/rc.d/rc.local

/sbin/route add default gw 10.168.50.2

Проверка маршрута (шлюз по умолчанию):

# netstat -nr

После этих комманд наш сервер выйдет в Интернет!

Для проверки можно установить Midnight Commander:

# yum install mc -y

Потом уже можно установить network-config-network-tui и setuptool

# yum install system-config-network-tui setuptool -y

# setup

После этого можете конфигурировать интерфейсы в текстовой оболочке, что на много наглядней, чем правка конфигурационных файлов.

Расмотрим третий случай, когда нет конфигурационных файлов.

Третий случай это когда нет файлов /etc/sysconfig/network-scripts/ifcfg-eth*

Сетевые адаптеры не видны!

Например, допустим система имеет два сетевых интерфейса. Их само собой не видно…

# cat /etc/udev/rules.d/70-persistent-net.rules

В этом файле хранятся настройки карт, файл генерируется при старте системы менеджером устройств.

В нем нам интересно узнать mac адрес и обозначения сетевых карт.

Mac адрес берется с этого параметра ATTR{address}==»08:00:27:40:03:63″

Обозначение адаптера берется с этого параметра Name=»eth0″

Аналогичным образом смотрим настройки второй сетевой карты eth1.

После того как мы узнали Mac адрес и обозначение, можно приступать к созданию файлов ответственных за сетевые адаптеры ifcfg-eth0 и ifcfg-eth1

Mac адрес (ATTR{address}) вписываем за в HWADDR, получится так HWADDR=»08:00:27:40:03:63″ и пишем обозначение eth0 в DEVICE, получится так: DEVICE=eth0, ну и дальше как обычно прописываете IP адрес, маску, шлюз, броадкаст и bootproto, посмотрите внизу на примерные файлы:

# vi /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0

BROADCAST=10.168.50.255

HWADDR=08:00:27:f1:54:18

IPADDR=10.168.50.48

NETMASK=255.255.255.0

NETWORK=10.168.50.0

ONBOOT=yes

NAME=Internet
# vi /etc/sysconfig/network-scripts/ifcfg-eth1

DEVICE=eth1

BOOTPROTO=static

HWADDR=08:00:27:40:03:65

IPADDR=192.168.50.1

NETMASK=255.255.255.0

ONBOOT=yes

NAME=LOCAL
Если нет файла /etc/sysconfig/network, создаем его:

# vi /etc/sysconfig/network

NETWORKING=yes

HOSTNAME=ServakUpal

NETWORKING_IPV6=no
И перезагружаем компьютер:

# shutdown -r now

Или перезапускаем сетевую службу:

# service network restart

После перезагрузки проверяем наличие сетевых карт:

# ifconfig

Бывает, что иногда надо прописать статические маршруты

SIOCADDRT:No such process
Делаем так, описываем маршрут локальной сети за которой закреплен адаптер eth1:

# route add -net 192.168.1.0 netmask 255.255.255.0 dev eth1

Описываем маршрут под сети провайдера, адаптер eth0:

# route add -net 217.15.174.47 netmask 255.255.255.248 dev eth1

Добавляем маршрут по умолчанию:

# route add default gw 217.15.174.48

Открываем файл статических маршрутов:

# vi /etc/sysconfig/network-scripts/route-eth1

192.168.1.0/24 via 217.15.174.47 dev eth0
или

default via 217.15.174.47 dev eth0
# vi /etc/sysconfig/network-scripts/static-routes

any net 192.168.1.0 netmask 255.255.255.0 gw 217.15.174.47 eth0
Примечание: Обычно так маршруты не надо прописывать.

Отключение и удаление службы Network Manager

Эта служба помогает на обычном компьютере настраивать сетевые карты, но на серверах обычно ее отключают или вообще удаляют:

Отключение службы:

# service NetworkManager stop

# chkconfig —level 123456 NetworkManager off

Удаление Network Manager:

# yum remove dnsmasq -y

После этой процедуры, будет возможно править в ручную сетевые настройки.

xenserver = centos 5 repo

nano /etc/yum.repos.d/CentOS-Base.repo
nano /etc/yum.repos.d/CentOS-Vault.repo
enable=1

И радуемся тому что есть в репах, например:
yum -y install htop

udev правила xenserver centos — nic ordering

1. Вариант.
http://habrahabr.ru/post/204052/

2. Вариант.
Если при кривом рестарте системы. Посыпался файл /etc/udev/rules/*net*.rules, который в Xenserver 6.5 генериться из /etc/sysconfig/network-scripts/interface-rename.py, причем

[root@srv-xen1 ~]# /etc/sysconfig/network-scripts/interface-rename.py --list
Name  MAC                PCI           ethN  Phys  SMBios  Driver   Version     Firmware
eth0  1c:6f:65:21:2f:47  0000:04:00.0  eth0                r8169    2.3LK-NAPI  rtl_nic/rtl8168d-2.fw
eth2  00:80:48:5d:d2:66  0000:08:03.0  eth1                8139too  0.9.28

[root@srv-xen1 ~]# lspci -v | grep Ethernet
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 03)
08:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter (rev 10)
        Subsystem: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter

 

Причем если машина с Xenserver не видит Мастера Пула. То выгрузиться или перезагрузиться она не сможет тк. встает колом служба Xapi.

Вопрос решился таким способом:

[root@srv-xen1 ~]# mv /etc/udev/rules.d/60-net.rules /root/60-net.rules
[root@srv-xen1 ~]# shutdown -rf now

 

Но нормально машина не рестартанет, нужно дернуть ее руками или man shutdown

Накидаю на всякий случай данных по Udev.

http://support.citrix.com/article/CTX135809

Xenserver 6.5 nfs4 client default

1. Изменить дефолтную версию клиента по-умолчанию в файле /opt/xensource/sm/nfs.py на 4

Very simply, edit the file /opt/xensource/sm/nfs.py and change line 46 to use ‘4’ instead of ‘3’ :

DEFAULT_NFSVERSION = ‘4’

and reboot.

NFS mounts for SRs that support NFSv4 now all seem to come up using this (as seen in /etc/mtab). Manual entries in /etc/fstab can also be adjusted to specify nfs4 in the definition (such as for defining NFS export locations for backups and such), but the «tcp» option must be removed from the options list since it is for NFSv4 both the default and no longer supported as an option (I believe you can request udp as a specific alternative).

2. Рестарт серверов Xen.
3. Проверить маунтится ли клиент в локальную папку.
4. Если выдает ошибку mount: can’t get address for , то прописать в /etc/hosts все ip адреса серверов, например: 192.168.4.7 srv-xen1 srv-xen1.example.com
5. Пробовать подключать nfs в pool серверов Xen. Например: 192.168.4.10:/mnt/nfs.
Все.